electrical gremlin on my KLX 250 - how to fix / solve ??

Discussion in 'Technical' started by andamaniac, Feb 22, 2015.

  1. andamaniac

    andamaniac Member

    my KLX 250 keeps blowing the main 20mA fuse. sometimes after 10 minutes of driving, sometimes after 2 hours. i took it to the kawasaki dealership in Krabi (where i live). As I had expected, all they did was change the fuse and tell me "the problem is fixed sir".

    I tried and tried to get it through their heads that just changing the fuse does not fix the real problem. something is causing the fuse the blow. This reasoning was beyond them, unfortunately. To them, the problem was solved when the bike started again with the replacement fuse in it.

    So I then took the bike to a series of local mechanics. Everywhere the same thing : "We found out why your bike doesn't start : your main fuse is blown. We have now fixed your problem (put in a new fuse)." they tell me this with a big and proud smile.

    Can anyone here advise me on how to solve this ? There isn't a mechanic in this province who is capable, evidently. If I would just put a slice of aluminium foil in place of fuse, then it won't blow obviously, but what is the worst that could happen if I would do that ? Could it lead me to identify what the cause is ? Or will it then just fry the entire electrical circuit and everything in it ?
    Thx.
     
  2. Loading...


  3. Moto-Rex

    Moto-Rex Ol'Timer

    I had the same problem with my first KLX. What was causing my main fuse to blow was a wire rubbing on the frame and wearing through underneath the seat. I would pull very thing of it, seat, tank etc and check the wiring to see if its rubbing anywhere.

    I been carrying share fuses ever since, and have never needed them.

    Moto-Rex
     
  4. andamaniac

    andamaniac Member

    Thanks! I will check that out first thing tomorrow morning :)
     

Share This Page