Use of GTR / OSM map on Garmin 276C

Discussion in 'GPS Use, Tracks & Maps Discussion' started by John Aero, May 11, 2014.

  1. Hope GTR GPS experts can help. I use a Garmin 276C on bike trips - its a marine chart plotter and only GPS available 10 years or so ago that was waterproof and could handle routable road maps - yes was an "early adopter" of GPS on bikes and still think they are fairly essential for a good trip - not forgetting hard copy maps as well! It served me well on European tours utilising Garmin maps loaded via MapSource. I now want to use it with the GTR map and will have to use BaseCamp. The 276C is not recognised by BaseCamp, JaVaWa nor my Mac (10.9.2) as a USB mass storage devise - in fact any Garmin update (the same form factor is still used with GA GPS units) has to be done via a Windows machine. I say not recognised as USB storage device but it does show in BaseCamp under My Garmin Devices and can say transfer routes. The memory sticks used are old style proprietary Garmin ones so cannot load map on to these via a card reader. I have been through various trials (utilising info from other GTR posts by Oddvar and Heilong) inc loading map via JaVaWa on SD card and getting my 205W to read it successfully. I have also looked at some of the specialist GPS forums but they are much too technical and more to do with complexities of POI's and creating maps - all I want is a routable map of Thailand. I do not mind putting map onto my Mac hard drive. Any suggestions?
  2. G'day John,

    No expert on this at all..
    My work and back ground is in the IT field.

    I think you will be pushing the proverbial up hill with a pointed stick..
    10 years old GPS.. All the Operating systems and drivers as well as hardware have all moved on so far ahead.

    Not saying impossible.. But don't like your chances with old kit with new hardware and operating systems talking to each other.

    Not much help on solving the problem.
    If you can't get it going. May need to look at a newer model Garmin for the bike.

    In some companies that don't want to change hardware.. They keep an old PC and operating system off the network to run the old kit that can't run on the newer hardware and operating systems. Pick up an old Pentium II or III from a junk shop with XP or Windows 95 and compatible USB ports.

  3. Garmin changed to a new format of the map quite some time ago. They call this this the NT format or New Type. Older GPS'es can not read this format so your best bet is to find an old map or use the OSM map which still uses the older format for its maps.
  4. Javawa thanks for the response. According to Garmin the 276C is compatible with NT maps in fact, and I am not an expert (hence this thread!) but, have met off roaders / overlanders who use the 276C as it will apparently accept any map routable or not. I did manage to get the Malfreemaps loaded onto it last year when I was in Malaysia but the GTR / OSM map appears to have more detail certainly for Thailand so I want to use the GTR / OSM map and would consider it possible - have the opportunity in couple of weeks to try a Windows PC rather than my Mac.
    Yes Brian again thanks for the input and am well aware of companies painfully and inefficiently utilising outdated hardware or software as have worked for a few over the years and been involved in projects to implement replacement of such. As I said the form factor of this unit is still current and Garmin still issue fw updates - in prep to boating and biking time in Asia bought a factory exchange unit couple of years ago for a reasonable price so reluctant to replace.

    Would welcome more input but in any event will post results of trying a Windows PC.

  5. As I said I would come back with results from trying Windows so that understanding of issue resolution or not is available to all. I have actually resolved issue without using Windows. I basically loaded map via OSM site rather than the GTR link. Once map is selected the site has loader options for various OS inc Mac which I used. The downloaded map was recognised by Garmin MapInstall (and BaseCamp) and loaded correctly directly to my 276C. I say correctly as have tried it out and it is present and working (in route recalculation etc) but load took over 1 1/2 hours. Apparently the older Garmin units are USB 1 but don't recollect when using MapSource it taking as long as this but now have a working detailed (better than Malfreemaps) routable map. Thanks for the input and hope this helps other GTR GPS users.

Share This Page